PT-2008-05: VMware Multiple Products vmci.sys Privilege Escalation Vulnerability

Affected Software

VMware Workstation 6.0.x, 6.5.x
VMware Player 2.0.x, 2.5.x
VMware ACE 2.0.x
VMware Server 2.x

Product Link:

Severity Rating

Severity: Medium
Impact: Priviliege Escalation
Attack Vector: Local

Base Score: 6.6
Temporal Score: 5.2
Vector: (AV:L/AC:M/Au:S/C:C/I:C/A:C/E:P/RL:O/RC:C)

CVE: CVE-2009-1147

Vulnerability Description

Positive Technologies Research Team has discovered priviliege escalation vulnerabilities in VMware products.

The IOCTL handler in vmci.sys does not properly validate buffer data associated with the Irp object, which allows local users with administrative priviligies to gain SYSTEM privilieges..


Update to the latest product version:

Workstation 6.5.x Windows 6.5.2 build 156735 or later
Workstation 6.0.x Windows upgrade to at least 6.5.2

Player 2.5.x Windows 2.5.2 build 156735 or later
Player 2.0.x Windows upgrade to at least 2.5.2

ACE 2.5.x Windows 2.5.2 build 156735 or later
ACE 2.0.x Windows upgrade to at least 2.5.2

Server 2.x Windows 2.0.1 build 156745 or later

Refer to VMware KB article 1009826 on the steps that are needed to remediate this vulnerability on Windows-based hosts. This KB article is found at

Disclosure Timeline

10.14.2008 - Vendor notified
10.16.2008 - Vendor replied
10.16.2008 - Sent detailed information
04.03.2009 - Vendor released fixed versions
04.06.2009 - Public disclosure


This vulnerability was discovered by Nikita Tarakanov, Positive Technologies Research Team.


Complete list of vulnerability reports published by Positive Technologies Research Team: