PT-2009-05: CA Internet Security Suite Denial of Service Vulnerability

Affected Software

      Internet Security Suite r3
      Internet Security Suite r4 prior to
      Internet Security Suite r5 prior to

Product Link:

Severity Rating

Severity: Medium
Impact: Denial of Service
Attack Vector: Local

CVSS v2:
Base Score: 4.9
Vector: (AV:L/AC:L/Au:N/C:N/I:N/A:C)

CVE: CVE-2009-0682

Vulnerability Description

Positive Technologies Research Team has discovered a denial of service (DoS) vulnerability in CA Internet Security Suite.

The IOCTL handler in vetmonnt.sys does not properly validate buffer data associated with the Irp object, which allows local users to crash the system.


Install latest versions of Internet Security Suite through automatic update functionality.
CA Internet Security Suite r3 - upgrade to Internet Security Suite r5 and apply the latest updates
CA Internet Security Suite r4 - update your software to version
CA Internet Security Suite r5 - update your software to version

Disclosure Timeline

02/04/2009 - Vendor notified
02/04/2009 - Vendor response
02/04/2009 - Details sent
08/18/2009 - Vendor releases fixed version and details
08/25/2009 - Public disclosure


This vulnerability was discovered by Nikita Tarakanov, Positive Technologies Research Team.


Complete list of vulnerability reports published by Positive Technologies Research Team: