PT-2012-04: SQL Injection Vulnerability in Cisco Identity Services Engine Web Interface

Vulnerable product

Cisco Identity Services Engine
Version: 1.0.4.573 and earlier

Link:
http://www.cisco.com/en/US/products/ps11640/index.html

Severity level

Severity level: Medium
Impact: SQL Injection
Access Vector: Remote

CVSS v2:
Base Score: 4.0
Vector: (AV:N/AC:L/Au:S/C:P/I:N/A:N)

CVE: CVE-2012-3910

Product description

Cisco Identity Services Engine (ISE) is a security policy management and control platform.

Vulnerability description

The specialists of the Positive Research center have detected a SQL Injection vulnerability in Cisco ISE web interface.

Since special characters in some search form fields are not properly escaped, any user authenticated via web interface can execute SQL queries on the backend database.

How to fix

Update your system up to the latest version

Advisory status

13.01.2012 - Vendor is notified 
13.01.2012 - Vendor gets vulnerability details
12.04.2012 - Vendor releases fixed version and details
20.09.2013 - Public disclosure

Credits

The vulnerability was detected by Kirill Mosolov, Maxim Tsoy, Positive Research Center (Positive Technologies Company)

References

http://en.securitylab.ru/lab/PT-2012-04

Reports on the vulnerabilities previously discovered by Positive Research:

http://www.ptsecurity.com/research/advisory/
http://en.securitylab.ru/lab/

Threatscape
Visionary WAF – Constant innovation