PT-2017-02: Insufficient Permissions in Rockwell Automation Micrologix 1100 and 1400 PLC

Vulnerable product

Micrologix 1100
Version: 1763-L16AWA, 1763-L16BBB, 763-L16BWA, 1763-L16DWD series A and B before 15.000

Micrologix 1400
Version: 1766-L32AWA, 1766-L32BWA, 1766-L32BWAA, 1766-L32BXB, 1766-L32BXBA, 1766-L32AWAA series A and B before 16.000

Links:
http://www.rockwellautomation.com/

Severity level

Severity level: Low
Impact: Access Control Changing
Access Vector: Remote

CVSS v3:
Base Score: 2.7
Vector: (AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L)

CVE: CVE-2016-9338

Software description

Rockwell Automation Micrologix 1100 and 1400 are programmable logic controllers.

Vulnerability description

The specialists of the Positive Research center have detected an Insufficient Permissions vulnerability in Rockwell Automation Micrologix 1100 and 1400 PLC.

Vulnerability in Allen-Bradly MicroLogix 1100 and 1400 allows remote attackers with administrative privileges to remove all administrators that disables some functions of the affected device until its factory reset.

How to fix

Update the firmware of your device to the latest version

Advisory status

11.06.2015 - Vendor gets vulnerability details
05.01.2017 - Vendor releases fixed version and details
11.01.2017 - Public disclosure

Credits

The vulnerability was detected by Ilya Karpov, Positive Research Center (Positive Technologies Company)

References

http://en.securitylab.ru/lab/PT-2017-02
https://ics-cert.us-cert.gov/advisories/ICSA-16-336-06

Reports on the vulnerabilities previously discovered by Positive Research:

http://www.ptsecurity.com/ww-en/analytics/threatscape/
http://en.securitylab.ru/lab/

Threatscape
Visionary WAF – Constant innovation